diff options
author | Siddharth Ravikumar <sravik@bgsu.edu> | 2016-01-11 18:59:31 -0500 |
---|---|---|
committer | Siddharth Ravikumar <sravik@bgsu.edu> | 2016-01-11 18:59:31 -0500 |
commit | 6003883979433fd0b68fd4c9d125fbc7974008ce (patch) | |
tree | 2e46a1d23c9cb2f048cd162ee49422f00c3eb288 /setup.py | |
parent | 84a74768c00ade0c7ca44cb72b9b32f103653333 (diff) |
[bug fix] setup.py
Function for reading a file is defined in setup.py itself.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 9 |
1 files changed, 7 insertions, 2 deletions
@@ -20,13 +20,18 @@ from setuptools import setup, find_packages -from combox.file import read_file from combox._version import get_version + +def readf(filename): + with open(filename, 'r') as f: + return f.read() + + config = { 'name': 'combox', 'description': 'Encrypts files and scatters them across storage provided by Google Drive and Dropbox.', - 'long_description': read_file('README.rst'), + 'long_description': readf('README.rst'), 'version': get_version(), 'platforms': ['GNU/Linux', 'OS X'], 'license': 'GNU General Public License version 3 or later', |