diff options
author | Siddharth Ravikumar <sravik@bgsu.edu> | 2015-02-05 21:17:23 -0500 |
---|---|---|
committer | Siddharth Ravikumar <sravik@bgsu.edu> | 2015-02-05 21:17:23 -0500 |
commit | 7822ed1d829aa34fe9c92de24f1f68042b05ed64 (patch) | |
tree | b7e1a78b010d6fa433c975e0d36e22f36e04f152 /setup.py | |
parent | 16f346ac5f59c7ce7c1349c1436d0821c9e0ca4c (diff) |
setup.py: added 'console_scripts' under 'entry_points'
Now, whenever combox is installed using 'python setup.py install'
command, the setup script automatically puts an executed script in the
respective bin/ directory in Unix like operating systems.
According to the setuptools documentation[1], on Windows, it should
create a respective .exe file. This is yet to be tested.
[1]: https://pythonhosted.org/setuptools/setuptools.html#automatic-script-creation
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 3 insertions, 0 deletions
@@ -35,6 +35,9 @@ config = { 'pickledb'], 'packages': ['combox'], 'scripts': [], + 'entry_points': { + 'console_scripts': ['combox = combox.cbox:main'] + }, 'name': 'combox' } |