summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorSiddharth Ravikumar <sravik@bgsu.edu>2015-01-12 16:08:26 -0500
committerSiddharth Ravikumar <sravik@bgsu.edu>2015-01-12 16:08:26 -0500
commit286421c30599dee1f1aaee500f3bfed0bada6c5f (patch)
tree2a3b5141ba37ff21a8e591d079912e3c67f68c0d /setup.py
parent0986bcd4d4158f6d77481cfb93a056da5e066eb9 (diff)
added setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py38
1 files changed, 38 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..e8914c1
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,38 @@
+# Copyright (C) 2014 Combox author(s). See AUTHORS.
+#
+# This file is part of Combox.
+#
+# Combox is free software: you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# Combox is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Combox (see COPYING). If not, see
+# <http://www.gnu.org/licenses/>.
+
+
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
+config = {
+ 'description': 'Splits encrypted files between online file storage providers',
+ 'author': 'Siddharth Ravikumar',
+ 'url': '',
+ 'download_url': 'Where to download it.',
+ 'author_email': 'sravik@bgsu.edu',
+ 'version': '0.0.0',
+ 'install_requires': ['nose', 'watchdog', 'PyYAML'],
+ 'packages': ['combox'],
+ 'scripts': [],
+ 'name': 'combox'
+ }
+
+setup(**config)