summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorSiddharth Ravikumar <sravik@bgsu.edu>2015-12-21 22:31:52 -0500
committerSiddharth Ravikumar <sravik@bgsu.edu>2015-12-21 22:31:52 -0500
commit8316de841d291cdb4a214bd838eff01380cdeae9 (patch)
treee96e7f1da9ceb8f08a0700e73ecfe260d0e08040 /setup.py
parent9efb42752a1088ac1bcafc10f0b6aefd9895969d (diff)
Added combox._version module.
This module is the canonical place for getting version information.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index cd3f0ab..d4387f2 100644
--- a/setup.py
+++ b/setup.py
@@ -19,13 +19,13 @@
from setuptools import setup, find_packages
from combox.file import read_file
-
+from combox._version import get_version
config = {
'name': 'combox',
'description': 'Splits encrypted files between online file storage providers',
'long_description': read_file('README.rst'),
- 'version': '0.1.3',
+ 'version': get_version(),
'platforms': ['GNU/Linux', 'OS X'],
'license': 'GNU General Public License version 3 or later',
'url': 'https://ricketyspace.net/combox/',
@@ -34,7 +34,7 @@ config = {
'author_email': 'sravik@bgsu.edu',
'install_requires': ['watchdog', 'PyYAML', 'pycrypto',
'simplejson', 'pickledb'],
- 'tests_require': ['nose'],
+ 'tests_require': ['nose', 'mock'],
'test_suite': 'nose.collector',
'packages': find_packages(exclude=['tests']),
'entry_points': {