summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 7 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 5fe4240..b0ca78a 100644
--- a/setup.py
+++ b/setup.py
@@ -20,13 +20,18 @@
from setuptools import setup, find_packages
-from combox.file import read_file
from combox._version import get_version
+
+def readf(filename):
+ with open(filename, 'r') as f:
+ return f.read()
+
+
config = {
'name': 'combox',
'description': 'Encrypts files and scatters them across storage provided by Google Drive and Dropbox.',
- 'long_description': read_file('README.rst'),
+ 'long_description': readf('README.rst'),
'version': get_version(),
'platforms': ['GNU/Linux', 'OS X'],
'license': 'GNU General Public License version 3 or later',