summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorrsiddharth <rsiddharth@ninthfloor.org>2015-10-01 11:01:46 -0400
committerrsiddharth <rsiddharth@ninthfloor.org>2015-10-01 11:01:46 -0400
commit0eb030201b54cef6162824066a617fe5385f3b2a (patch)
treebe843d2d52b465fb490132a8cb4dfd25ced10d19 /setup.py
parentcfea2dbfa5f39a92e2336b053f83f1f86db23cbb (diff)
added setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..c6caa81
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,19 @@
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
+config = {
+ 'description': 'LibrePlanet schedule generator',
+ 'author': 'rsiddharth',
+ 'url': 'URL to get it at.',
+ 'download_url': 'Where to download it.',
+ 'author_email': 'rsiddharth@ninthfloor.org',
+ 'version': '0.0',
+ 'install_requires': ['nose'],
+ 'packages': ['lpschedule'],
+ 'scripts': [],
+ 'name': 'lpschedule-generator'
+ }
+
+setup(**config)