summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorrsiddharth <rsd@gnu.org>2015-12-19 17:41:41 -0500
committerrsiddharth <rsd@gnu.org>2015-12-19 17:41:41 -0500
commit77f0b522e1a16b1dba36432d5aa7a099bfe84403 (patch)
tree799755555aa8dc9e7f219c65619a4f74e1650d79 /setup.py
parentbf36773eeb0c858d064e13c96a2fd2e93757f710 (diff)
updated lps_gen.RenderHTML
- Now handles the case when the template does not exist. - HTML output is now prettified by BeautifulSoup.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 7 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index c31e669..c767ef9 100644
--- a/setup.py
+++ b/setup.py
@@ -1,3 +1,6 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+#
# Copyright (C) 2015 lpschedule-generator contributors. See CONTRIBUTORS.
#
# This file is part of lpschedule-generator.
@@ -22,14 +25,15 @@ except ImportError:
from distutils.core import setup
config = {
+ 'name': 'lpschedule-generator',
'description': 'LibrePlanet schedule generator',
'author': 'rsiddharth',
'url': 'https://notabug.org/rsd/lpschedule-generator/',
'author_email': 'rsd@gnu.org',
'version': '0.0',
- 'install_requires': ['nose', 'mistune', 'Jinja2'],
+ 'install_requires': ['nose', 'mock', 'mistune', 'Jinja2', 'beautifulsoup4'],
'py_modules': ['lps_gen'],
- 'name': 'lpschedule-generator'
- }
+ 'data_files':[('templates',['templates/lp-sch-2016.jinja2'])],
+}
setup(**config)