summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorrsiddharth <rsd@gnu.org>2015-12-20 11:58:04 -0500
committerrsiddharth <rsd@gnu.org>2015-12-20 11:58:04 -0500
commitab2abaa0a67b69650fc68e29ef96d41285e4ac0f (patch)
tree8048acb7607e93b58196cde2331fd6fc43edc5ba /setup.py
parent6fe9304e84b4540c18013bc2735bfd2f709fc779 (diff)
setup.py: added `test_suite`.
Now tests can be run with `python setup.py test` command.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index a8c3712..9a43f25 100644
--- a/setup.py
+++ b/setup.py
@@ -38,6 +38,7 @@ config = {
'author_email': 'rsd@gnu.org',
'install_requires': ['mistune', 'Jinja2', 'beautifulsoup4'],
'tests_require': ['nose', 'mock'],
+ 'test_suite': 'nose.collector',
'py_modules': ['lps_gen'],
'packages': find_packages(exclude=['tests']),
'package_data': { 'lpschedule_generator': ['templates/*.jinja2'] },