summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2019-11-01 19:33:24 -0400
committerrsiddharth <s@ricketyspace.net>2019-11-01 19:33:24 -0400
commite2f84b9a52b33c636ad189507271927a5a7da8da (patch)
tree6f50bab74382a3782b26e2611afb663d3a0d882a /setup.py
parentb92c433f84f98087742a00a527552561f5c66e79 (diff)
setup.py: Flesh it out.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 20 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d6af624..36d2689 100644
--- a/setup.py
+++ b/setup.py
@@ -9,12 +9,31 @@
from setuptools import find_packages, setup
+with open('README.md', 'r') as f:
+ ldesc = f.read()
+
setup(
- name='dingy',
+ name='nfsw',
version='0.1.0.dev0',
+ license='ISC',
+ author='rsiddharth',
+ author_email='s@ricketyspace.net',
+ description='A quirky text based adverture',
+ long_description=ldesc,
+ long_description_content_type='text/markdown',
+ url='https://ricketyspace.net/nfsw',
packages=find_packages(),
include_package_data=True,
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Environment :: Web Environment',
+ 'Framework :: Flask',
+ 'License :: OSI Approved :: ISC License (ISCL)',
+ 'Operating System :: POSIX :: BSD :: OpenBSD',
+ 'Topic :: Games/Entertainment',
+ ],
+ platforms='OpenBSD',
zip_safe=False,
install_requires=[
'flask==1.1.1',